码迷,mamicode.com
首页 > 其他好文 > 详细

uva 116

时间:2015-08-07 20:00:58      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson‘s route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an 技术分享 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps‘‘ so that it represents a horizontal cylinder. Legal steps are illustrated below.

技术分享

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different 技术分享 matrices are shown below (the only difference is the numbers in the bottom row).

技术分享

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by 技术分享 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path‘s weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

 Status


//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> pii;
#define M 12
#define N 110

LL a[M][N];
LL d[M][N];
int m, n;

int main()
{
    while(~scanf("%d%d", &m, &n))
    {
        for(int i = 0; i < m; i++)
        for(int j = 0; j < n; j++)
        scanf("%lld", &a[i][j]);
        memset(d, 0x3f, sizeof d);

        LL ans = INF;
        int pos;
        for(int j = n - 1; j >= 0; j--)
        for(int i = 0; i < m; i++)
        {
            if(j == n - 1) d[i][j] = a[i][j];
            else  d[i][j] = min(min(d[(i-1+m)%m][j+1], d[i][j+1]), d[(i+1)%m][j+1]) + a[i][j];

            if(!j)
            {
                if(ans > d[i][j])
                {
                    ans = d[i][j];
                    pos = i;
                }
            }
        }

        LL cur = ans;
        n == 1 ? printf("%d\n", pos + 1) : printf("%d ", pos + 1);
        for(int j = 1; j < n; j++)
        {
            cur -= a[pos][j-1];
            int go[3] = {(pos - 1 + m) % m, pos, (pos + 1) % m};
            sort(go, go + 3);
            for(int i = 0; i < 3; i++)
            {
                if(d[go[i]][j] == cur)
                {
                    pos = go[i];
                    j == n - 1 ? printf("%d\n", pos + 1) : printf("%d ", pos + 1);
                    break;
                }
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 116

标签:acm   uva   

原文地址:http://blog.csdn.net/dojintian/article/details/47342191

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!