标签:hdu 1231 acm max sum
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 178139 Accepted Submission(s): 41558
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
再谈动态规划!
具体代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int dp[100001];
int a[100001];
int s[100001];
int main()
{
int T,k,count=0;
cin>>T;
while(T--)
{
cin>>k;
count++;
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
s[0]=s[1]=1;
for(int i=1;i<=k;i++)
{
cin>>a[i];
}
for(int i=1;i<=k;i++)
{
if(dp[i-1]+a[i]>=a[i])
{
dp[i]=dp[i-1]+a[i];
s[i]=s[i-1];
}
else
{
dp[i]=a[i];
s[i]=i;
}
}
int start=1,end=1;
int max=dp[1];
for(int i=2;i<=k;i++)
{
if(max<dp[i])
{
max=dp[i];
start=s[i];
end=i;
}
}
cout<<"Case "<<count<<":"<<endl;
cout<<max<<" "<<start<<" "<<end<<endl;
if(T!=0)cout<<endl;
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
杭电(hdu)ACM 1003 Max Sum
标签:hdu 1231 acm max sum
原文地址:http://blog.csdn.net/it142546355/article/details/47341685