标签:杭电 1686
Oulipo
Time Limit : 3000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 80 Accepted Submission(s) : 51
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W|
denotes the length of the string W). One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
分析:
写这道题前会长给我们讲了kmp的用法,但是当时一直迷迷糊糊的,没有搞得太懂,下去自己又看了一下。结合这道题写下自己的理解。
这道题的意思是从第二组数据中找出第一组数据出现的次数,用平常的方法就是一个一个的找,用俩个for循环,这时候的用时就是(n*m);
但是用kmp就能很快的解决这个题,去掉不必要的搜索。详解在代码中体现。
代码:
#include<cstdio>
#include<cstring>
const int max=10010;
char s1[max],s2[max*100];
int p[max];
int len1,len2;
int cnt;
void getp()//kmp的优化,先找到第一个串的规律,消除不必要的搜索。
{
int i=0,j=-1;
p[0]=-1;
while(i<len1)
{
if(j==-1||s1[i]==s2[j])
{
i++,j++;
p[i]=j;
}
else
j=p[j];
}
}
void kmp()//正式开始匹配。
{
getp();
int i=0,j=0;
while(i<len2)
{
if(j==-1||s1[j]==s2[i])//当第i个字符和第j个字符相等的时候就把j的位置 ,匹配下一个。
{
i++,j++;
if(j==len1)//当满足第一个字符串的时候,计数。
cnt++;
}
else//当俩个不相等的时候,就把第一个字符串向右移,从新匹配。
j=p[j];
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
cnt=0;
scanf("%s%s",s1,s2);
len1=strlen(s1);
len2=strlen(s2);
kmp();
printf("%d\n",cnt);
}
return 0;
}
hdoj 1686 Oulipo【kmp】
标签:杭电 1686
原文地址:http://blog.csdn.net/qq_21654717/article/details/47340717