码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1711 Number Sequence【求字串在母串中第一次出现的位置】

时间:2015-08-07 21:51:48      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15017    Accepted Submission(s): 6585


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
#include<stdio.h>
#include<string.h>
#define MAX 10010
int n,m;
int b[MAX],a[MAX*100];
int next[MAX];
void getmap()
{
	int i;
	for(i=0;i<n;i++)
	scanf("%d",&a[i]);
	for(i=0;i<m;i++)
	scanf("%d",&b[i]);
}
void getfail()
{
	int i,j;
	next[0]=next[1]=0;
    for(i=1;i<m;i++)
    {
    	j=next[i];
    	while(j&&b[i]!=b[j])
    	    j=next[j];
    	next[i+1]=b[i]==b[j]?j+1:0;
	}
}
void kmp()
{
	int i,j=0;
	int ok=0;
	for(i=0;i<n;i++)
	{
		while(j&&a[i]!=b[j])
		    j=next[j];
		if(a[i]==b[j])
		    j++;
		if(j==m)
		{
			ok=1;
			printf("%d\n",i-m+2);//难点在这里 
			return ;
		}
	}
	if(!ok)
	printf("-1\n"); 
}
int main()
{
	int i,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		getmap();
		getfail();
		kmp();
	}
	return 0;
}

  

hdoj 1711 Number Sequence【求字串在母串中第一次出现的位置】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4711898.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!