码迷,mamicode.com
首页 > 其他好文 > 详细

poj1113 Wall 凸包

时间:2015-08-07 22:27:06      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.

The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.
Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200
Sample Output

1628
Hint

结果四舍五入就可以了
Source

Northeastern Europe 2001

城堡围墙长度最小值 = 城堡顶点坐标构成的散点集的凸包总边长 + 半径为L的圆周长

凸包问题,。直接用了凸包模板。。凸包的点全部存入save数组中了。相邻两边取出来求距离。。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAX 1005
#define INF 1000000000

int n,L;
struct point  //11?ìμ?
{
    double x,y;
}p[MAX];

point save[1005];  //′?μ?

int xmult(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
bool cmp(const point& a,const point &b)
{
    if(a.y == b.y)return a.x < b.x;
    return a.y < b.y;
}
int Graham(point *p,int n)
{
    int i;
    sort(p,p + n,cmp);
    save[0] = p[0];
    save[1] = p[1];
    int top = 1;
    for(i = 0;i < n; i++)
    {
        while(top && xmult(save[top],p[i],save[top-1]) >= 0) top--;
        save[++top] = p[i];
    }
    int mid = top;
    for(i = n - 2; i >= 0; i--)
    {
        while(top>mid&&xmult(save[top],p[i],save[top-1])>=0) top--;
        save[++top]=p[i];
    }
    return top;
}

double dis(point a,point b)
{
    double x=a.x-b.x;
    double y=a.y-b.y;
    return sqrt(x*x+y*y);
}

int main()
{
    scanf("%d %d",&n,&L);
    int i;
    for(i=0;i<n;i++) scanf("%lf %lf",&p[i].x,&p[i].y);
    int tot=Graham(p,n);
    double ans=L*2*3.14159265;
    for(i=0;i<tot;i++)
    {
        ans+=dis(save[i],save[(i+1)%tot]);
    }
    printf("%.0f\n",ans);
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj1113 Wall 凸包

标签:

原文地址:http://blog.csdn.net/xtulollipop/article/details/47344717

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!