标签:poj2752
Seek the Name, Seek the Fame
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 14154 |
|
Accepted: 7049 |
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape
from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father‘s name and the mother‘s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
Source
分析:
意思就是把next数组的数字从小到大输出。
代码:
#include<cstdio>
#include<cstring>
const int max= 400400;
char str[max];
int next[max];
int len;
int gg[max];
void kmp(){
int i=0,j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||str[i]==str[j])
{
i++,j++;
next[i]=j;
}
else
j=next[j];
}
}
int main()
{
while(scanf("%s",str)!=EOF)
{
int dd=0;
len=strlen(str);
kmp();
for(int i=len;next[i]!=-1;i=next[i])
gg[dd++]=i;
printf("%d",gg[dd-1]);
for(int i=dd-2;i>=0;i--)
printf(" %d",gg[i]);
printf("\n");
}
return 0;
}
poj 2752Seek the Name, Seek the Fame 【kmp】
标签:poj2752
原文地址:http://blog.csdn.net/qq_21654717/article/details/47344603