码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2406 Power Strings 【kmp】

时间:2015-08-07 22:28:09      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:poj 2406

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 37564   Accepted: 15532

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
 
分析:
查找最大序列数。
代码:
 
#include<cstdio>
#include<cstring>
const int max= 1000100;
char str[max];
int p[max];
int cnt;
int len;
void getp()
{
	 len=strlen(str);
	int i=0,j=-1;
	p[0]=-1;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++,j++;
			p[i]=j;
		}
		else j=p[j];
	}
}
int main()
{
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,".")==0)
		break;
		getp();
		cnt=1;
//		for(int i=0;i<len;i++)
//		printf("%d ",p[i]);
		if(len%(len-p[len])==0)
		cnt=len/(len-p[len]);
		printf("%d\n",cnt);
	}
	return 0;
}

版权声明:博主情人,外人误碰!!!

poj 2406 Power Strings 【kmp】

标签:poj 2406

原文地址:http://blog.csdn.net/qq_21654717/article/details/47344581

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!