码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1458 Common Subsequence

时间:2015-08-08 09:05:41      阅读:91      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1458

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 43077   Accepted: 17439

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2

技术分享

 

#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
#define N 500
#define max(a, b)(a > b ? a : b)

char s1[N], s2[N];

int main()
{
    int len1, len2, i, j, maps[N][N];
    while(~scanf("%s%s", s1, s2))
    {
        memset(maps, 0, sizeof(maps));
        len1 = strlen(s1);
        len2 = strlen(s2);
        for(i = 1 ; i <= len1 ; i++)
        {
            for(j = 1 ; j <= len2 ; j++)
            {
                if(s1[i - 1] == s2[j - 1])
                    maps[i][j] = maps[i - 1][j - 1] + 1;
                else
                    maps[i][j] = max(maps[i - 1][j], maps[i][j - 1]);
            }
        }
        printf("%d\n", maps[len1][len2]);
    }
    return 0;
}

 


技术分享
技术分享

poj 1458 Common Subsequence

标签:

原文地址:http://www.cnblogs.com/qq2424260747/p/4712507.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!