码迷,mamicode.com
首页 > 其他好文 > 详细

POJ Fibonacci 3070【矩阵快速幂】

时间:2015-08-08 10:33:23      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:

Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10931   Accepted: 7770

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享.

Source


就是矩阵快速幂,裸题。

#include <stdio.h>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define Mod 10000

using namespace std;

int res[5][5];
int mat[5][5];

void Matmul(int x[5][5],int y[5][5])
{
    int t[5][5]={0};
    for(int i=0;i<2;i++){
        for(int k=0;k<2;k++){
            if(x[i][k]){
                for(int j=0;j<2;j++)
                    t[i][j]=(t[i][j]+(x[i][k]*y[k][j]))%Mod;
            }
        }
    }
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            x[i][j]=t[i][j];
        }
    }
}

void Matrix(int x[5][5],int n)
{
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            res[i][j]=(i==j);
        }
    }
    while(n){
        if(n&1)Matmul(res,x);
        Matmul(x,x);
        n>>=1;
    }
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        mat[0][0]=mat[0][1]=mat[1][0]=1;
        mat[1][1]=0;
        if(n==-1)break;
        if(n==0){
            printf("0\n");
            continue;
        }

        Matrix(mat,n);
        printf("%d\n",res[0][1]);
    }
    return 0;
}


版权声明:本文为博主原创文章,转载请注明出处。

POJ Fibonacci 3070【矩阵快速幂】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47355373

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!