码迷,mamicode.com
首页 > 其他好文 > 详细

周赛题目

时间:2015-08-08 16:40:46      阅读:90      评论:0      收藏:0      [点我收藏+]

标签:数据结构   算法   for循环   

Description

X soldiers from the famous " *FFF* army" is standing in a line, from left to right. 
You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right. 
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don‘t know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right. 
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input

The rst line has a number T (T <= 10) , indicating the number of test cases. 
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 105) 
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output

For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input

2 3 1 2 4 3 1001 1002 1004
 

Sample Output

Case #1: 3 Case #2: 3
 

思路:从左到右进行报数,一定有一个人报错,输出报错的那个人的位置

#include<stdio.h>
#include<string.h>
#define N 100001
int main()
{
  int n,m,i,j,T;
int a[N];
  int k=1;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d",&n);
    for(i=0;i<=n-1;i++)
    {
      scanf("%d",&a[i]);
    }
    m=1;
    for(i=1;i<=n-1;i++)
    {
       if(a[i]!=a[i-1]+1)
       {

        m=i+1;
        break;
       }

    }
 printf("Case #%d: %d\n",k++,m);
  }
   return 0;
}






版权声明:本文为博主原创文章,未经博主允许不得转载。

周赛题目

标签:数据结构   算法   for循环   

原文地址:http://blog.csdn.net/sh_tomorrow/article/details/47358241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!