码迷,mamicode.com
首页 > 其他好文 > 详细

Ignatius and the Princess IV 水

时间:2015-08-08 18:17:41      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:c++   编程   

B - Ignatius and the Princess IV
Time Limit:1000MS     Memory Limit:32767KB     64bit IO Format:%I64d & %I64u

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output

For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input

5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output

3 5 1
 
PS  数组开的很大 所以要用全局变量,wa好几次才发现!
AC代码:
#include <iostream>
#include <algorithm>
#define maxn 1000000
int my[maxn];
using namespace std;
int main(){
    int n;

    while(cin>>n){
        for(int i=0;i<n;++i)
            cin>>my[i];
        int special_number=(n+1)/2;
        sort(my,my+n);
        for(int i=0;i<n;++i){
            int ans=1;
            bool flag=false;
            while(my[i]=my[i+1]){
                if(++ans>=special_number){
                    cout<<my[i]<<'\12';
                    flag=true;
                    break;
                    }
                i++;
            }
            if(flag)break;
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Ignatius and the Princess IV 水

标签:c++   编程   

原文地址:http://blog.csdn.net/zp___waj/article/details/47360397

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!