码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4006 The kth great number

时间:2015-08-08 18:24:56      阅读:101      评论:0      收藏:0      [点我收藏+]

标签:stl   set   

hdu 4006 的传送门->

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

题目大意: 就是I表示增加一个数,Q表示输出第k大的数,

解题思路:就是用set 简单搞一下就好了。。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
//注意啦!!!!
multiset <int> s;//注意这里是muiltiset,是有重复的
multiset <int> ::iterator it;
char st[2];
int main()
{
    int m,k,x;
    while(~scanf("%d%d",&m,&k))
    {
        s.clear();
        while(m--)
        {
            scanf("%s",st);
            if(st[0] == ‘I‘)
            {
                scanf("%d",&x);
                s.insert(x);
                if(s.size()>k)
                    s.erase(s.begin());
            }
            else
            {
                it=s.begin();
                printf("%d\n",*it);
            }
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 4006 The kth great number

标签:stl   set   

原文地址:http://blog.csdn.net/qingshui23/article/details/47359631

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!