码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3264 Balanced Lineup(st或者线段树)

时间:2015-08-09 02:02:05      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:rmq问题st算法   线段树单点更新   

A - Balanced Lineup
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

st算法

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 50005
int n,q;
int dp[maxn][30],d[maxn][30],a[maxn];
void rmq(){
   for(int i=1;i<=n;i++)dp[i][0]=a[i],d[i][0]=a[i];
   for(int j=1;(1<<j)<=n;j++){
    for(int i=1;i+(1<<j)-1<=n;i++){
        dp[i][j]=min(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        d[i][j]=max(d[i][j-1],d[i+(1<<(j-1))][j-1]);
    }
   }
}
int query1(int l,int r){
    int k=0;
    while((1<<(k+1))<=r-l+1)k++;
    return min(dp[l][k],dp[r-(1<<k)+1][k]);
}
int query2(int l,int r){
    int k=0;
    //int k=floor(log(R-L+1.0)/log(2.0));
    while((1<<(k+1))<=r-l+1)k++;
    return max(d[l][k],d[r-(1<<k)+1][k]);
}
int main()
{
    int u,v;
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&q)){
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        rmq();
        for(int i=0;i<q;i++){
            scanf("%d%d",&u,&v);
            printf("%d\n",query2(u,v)-query1(u,v));
        }

    }
}
线段树
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 50005
#define inf 0x3f3f3f3f
int n,q;
int a[maxn],ll[maxn<<1],rr[maxn<<1],mi[maxn<<1],ma[maxn<<1];
inline void pushup(int i){
    ma[i]=max(ma[i<<1],ma[i<<1|1]);
    mi[i]=min(mi[i<<1],mi[i<<1|1]);
}
void build(int l,int r,int i){
    ll[i]=l;
    rr[i]=r;
    if(l==r){
        mi[i]=a[l];
        ma[i]=a[l];
        return ;
    }
    int m=(ll[i]+rr[i])>>1,ls=i<<1,rs=ls|1;
    build(l,m,ls);
    build(m+1,r,rs);
    pushup(i);
}
int query1(int l,int r,int i){
    if(l<=ll[i]&&rr[i]<=r){
        return mi[i];
    }
    int m=(ll[i]+rr[i])>>1,ls=i<<1,rs=ls|1;
    int ans=inf;
    if(l<=m)ans=min(ans,query1(l,r,ls));
    if(m<r)ans=min(ans,query1(l,r,rs));
    return ans;
}
int query2(int l,int r,int i){
    if(l<=ll[i]&&rr[i]<=r){
        return ma[i];
    }
    int m=(ll[i]+rr[i])>>1,ls=i<<1,rs=ls|1;
    int ans=0;
    if(l<=m)ans=max(ans,query2(l,r,ls));
    if(m<r)ans=max(ans,query2(l,r,rs));
    return ans;
}
int main()
{
    int u,v;
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&q)){
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        build(1,n,1);
        for(int i=0;i<q;i++){
            scanf("%d%d",&u,&v);
            printf("%d\n",query2(u,v,1)-query1(u,v,1));
        }

    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3264 Balanced Lineup(st或者线段树)

标签:rmq问题st算法   线段树单点更新   

原文地址:http://blog.csdn.net/u013497977/article/details/47364603

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!