码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 1611 The Suspects

时间:2015-08-09 12:36:46      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:并查集

Poj 1611 的传送门

              ***The Suspects***

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

题目大意:第一行为两个整数n和m, 其中n是学生的数量, m是团体的数量。0 < n <= 30000,0 <= m <= 500。
每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。
紧随其后的是团体的成员列表,每组一行。
每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。
n = m = 0表示输入结束,不需要处理。
然后输出可能感染的人的个数

解题思路:并查集:

具体详见代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 30010;

int fa[maxn];//父亲节点
int rank[maxn];//rank[x]就是表示x的高度上的一个上界
int sum[maxn];//sum[]存储该集合中元素个数,并在集合合并时更新sum[]即可
void Init(int x)//创建单元集
{
    fa[x]=x;
    sum[x]=1;
    rank[x]=0;
    return ;
}

int Find(int x)//递归找父亲,路径压缩
{
    if(x != fa[x])
        fa[x]=Find(fa[x]);
    return fa[x];
}

void Union(int a, int b)//让rank比较高的作为父亲节点
{
    a=Find(a);
    b=Find(b);
    if(a == b)
        return ;
    if(rank[a] > rank[b])
    {
        fa[b]=a;
        sum[a]+=sum[b];
    }
    else
    {
        fa[a]=b;
        if(rank[a] == ran[b])
            rank[b]++;
        sum[b]+=sum[a];
    }
}
int main()
{
    int m,n,k,a,b;
    while(cin>>m>>n)
    {
        if(!m && !n)
            break;
        if(n == 0)
        {
            puts("1");
            continue;
        }
        for(int i=0; i<m; i++)
            Init(i);
        while(n--)
        {
            cin>>k>>a;
            k--;
            while(k--)
            {
                cin>>b;
                Union(a, b);
            }
        }
        cout<<sum[Find(0)]<<endl;
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Poj 1611 The Suspects

标签:并查集

原文地址:http://blog.csdn.net/qingshui23/article/details/47374391

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!