码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 348 Optimal Array Multiplication Sequence(最优矩阵链乘)

时间:2015-08-09 20:41:53      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:区间dp   最优矩阵链乘   optimal array multip   

L - Optimal Array Multiplication Sequence
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

技术分享

Given two arrays A and B, we can determine the array C = AB using the standard definition of matrix multiplication:

技术分享

The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let‘s say that rows(A) andcolumns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A)columns(Bcolumns(A). For example, if A is a 技术分享 array, and B is a 技术分享 array, it will take 技术分享 , or 3000 multiplications to compute the C array.

To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if XY, and Z are arrays, then to compute XYZ we could either compute (XYZ or X (YZ). Suppose X is a 技术分享 array, Y is a 技术分享 array, and Z is a 技术分享 array. Let‘s look at the number of multiplications required to compute the product using the two different sequences:

(XYZ

  • 技术分享 multiplications to determine the product (X Y), a 技术分享 array.
  • Then 技术分享 multiplications to determine the final result.
  • Total multiplications: 4500.

X (YZ)

  • 技术分享 multiplications to determine the product (YZ), a 技术分享 array.
  • Then 技术分享 multiplications to determine the final result.
  • Total multiplications: 8750.

Clearly we‘ll be able to compute (XYZ using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplications required.

Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.

Output

Assume the arrays are named 技术分享 . Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.

Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0

Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))
区间dp模型(记忆化写法和递推已均ac)
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 11
#define inf 0x3f3f3f3f
int a[maxn],b[maxn];
int dp[maxn][maxn];
int p[maxn][maxn];
int dfs(int l,int r){
    //cout<<l<<" "<<r<<endl;
     if(dp[l][r]>0)return dp[l][r];
     if(l==r)return dp[l][r]=0;
     int ans=inf;
     int temp;
     for(int i=l;i<r;i++){
       temp=dfs(l,i)+dfs(i+1,r)+a[l]*b[i]*b[r];
       if(temp<ans){
           ans=temp;
           p[l][r]=i;
       }
     }
     return  dp[l][r]=ans;
}

void solve(int n){
     for(int i=1;i<=n;i++)dp[i][i]=0;
     for(int d=1;d<n;d++){
        for(int i=1;i<=n-d;i++){
            int j=i+d;
            int ans=inf;
            for(int k=i;k<j;k++){
                int temp=dp[i][k]+dp[k+1][j]+a[i]*b[k]*b[j];
                if(temp<ans){
                    ans=temp;
                    p[i][j]=k;
                }
            }
            dp[i][j]=ans;
        }
     }
}
void print_path(int l,int r){
     if(l>r)return;
     if(l==r)printf("A%d",l);
     else{
        printf("(");
        print_path(l,p[l][r]);
        printf(" x ");
        print_path(p[l][r]+1,r);
        printf(")");
     }
}
int main()
{
    int n;
    int t=0;
    freopen("in.txt","r",stdin);
    while(~scanf("%d",&n)&&n){
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a[i],&b[i]);
        }
        //dfs(1,n);
        solve(n);
        printf("Case %d: ",++t);
        print_path(1,n);
        printf("\n");
    }
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

UVA 348 Optimal Array Multiplication Sequence(最优矩阵链乘)

标签:区间dp   最优矩阵链乘   optimal array multip   

原文地址:http://blog.csdn.net/u013497977/article/details/47379223

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!