码迷,mamicode.com
首页 > 其他好文 > 详细

poj2506 大数递推

时间:2015-08-09 22:32:30      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8205   Accepted: 3974

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.
技术分享

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int a[300][200];
    memset(a,0,sizeof(a));
    a[0][0]=1;
    a[1][0]=1;
    a[2][0]=3;
    for(int i=3; i<=250; i++)
    {
        for(int j=0; j<=100; j++)
        {
            a[i][j]+=(a[i-1][j]+a[i-2][j]+a[i-2][j]);
            if(a[i][j]>=10)
            {
                int t=a[i][j];
                a[i][j]%=10;
                a[i][j+1]+=t/10;
            }
        }
    }
    int n;
    while(cin>>n)
    {
        if(n==0)
            cout<<1<<endl;
        else
        {
            int i=100;
            while(!a[n][i])
            {
                i--;
            }
            for(int j=i; j>=0; j--)
                cout<<a[n][j];
            cout<<endl;
        }

    }
}
/*
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
    public static void main(String[] args)
    {
       Scanner cin = new Scanner ( System.in );
       BigInteger arr[]=new BigInteger[300];
       arr[1]=BigInteger.ONE;
        arr[0]=BigInteger.ONE;
       arr[2]=BigInteger.valueOf(3);
       arr[3]=BigInteger.valueOf(5);
       for(int i=4;i<=270;i++){
    	   arr[i]=arr[i-2].multiply(BigInteger.valueOf(2));
    	   arr[i]=arr[i].add(arr[i-1]);
       }
    	int t;
       while(cin.hasNext()==true){
    	   t=cin.nextInt();
    	   System.out.println(arr[t].toString());    	   
       }
    }
}

*/


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj2506 大数递推

标签:

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47380767

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!