码迷,mamicode.com
首页 > 其他好文 > 详细

ACdream 1113 The Arrow (概率dp求期望)

时间:2015-08-10 00:18:43      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:acdream   概率dp   


The Arrow

Time Limit: 2000/1000MS (Java/Others)
Memory Limit: 128000/64000KB (Java/Others)

Problem Description

The history shows that We need heroes in every dynasty. For example, Liangshan Heroes. People hope that these heroes can punish the bad  guys and recover the justice. Nowadays, we also need heroes to provent us from being chopped, or being attacked by a bomb. 

Kuangbin is a very very very very very.... (very * 1e9 ) good boy, after he knows The Arrow, he want to be The Arrow of China. But he is also a little afraid of being killed by the bad guys. So he decides to throw dices to make the decision.

The dice is a cube with 1 2 3 4 5 6 on it‘s sides. When he throws a dice, every number is of the same probablity to appear. He will write down a number N in the paper at first, and then throw the dice. When the sum of the number he throwed is less than N, he will keep throwing. But if the sum exceeds N, this throwing does not count.

For example, If the sum is 5,and N is 6, if we throw 2, 5 + 2 > 6, then  the sum keeps to be 5.

If he can end the throwing in a certain time, he will make the decision to become The Arrow.

Now , kuangbin wonders that what‘s the expectation of the time of throwing dices.

Input

First line, The number of cases t <= 100

In the next t lines, there will be t numbers.

every number is not bigger than 100000

Output

Each test output a number rounded to the second digit.

Sample Input

1
1

Sample Output

6.00

Source

wuyiqi

Manager

wuyiqi

题目链接:http://acdream.info/problem?pid=1113

题目大意:掷骰子,如果之前掷到的点数和加当前掷到的点数大于n则不做处理,否则累加,求掷到数字n掷的次数的期望

题目分析:首先dp[n]肯定是0,往前推
得到dp[i] = cnt / 6dp[i] + 1/6dp[i - 1] + 1/6dp[i - 2] + ... + 1/6dp[i - 6] + 1,这里cnt表示的是之前点数和加上当前点数大于n的当前点数的个数,化简这个式子递推dp[i]即可

#include <cstdio>
#include <cstring>
int const MAXN = 1e5 + 5;
double dp[MAXN];

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        memset(dp, 0, sizeof(dp));
        dp[n] = 0.0;
        for(int i = n - 1; i >= 0; i--)
        {
            dp[i] = 0;
            int cnt = 0;
            for(int j = 1; j <= 6; j++)
            {
                if(i + j > n)
                    cnt ++;
                else
                    dp[i] += dp[i + j];
            }
            dp[i] += 6;
            dp[i] /= (6 - cnt);
        }
        printf("%.2f\n", dp[0]);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

ACdream 1113 The Arrow (概率dp求期望)

标签:acdream   概率dp   

原文地址:http://blog.csdn.net/tc_to_top/article/details/47382111

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!