码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1260 Pearls(DP)

时间:2015-08-10 09:27:38      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:

Pearls
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7946   Accepted: 3948

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
prices remain the same. 
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

Source




   题意:有n种珍珠,珍珠的品质按照输入的顺序由小到大排列,每一种都有要买的个数,需要付的价钱 = (本种珍珠需要买的个数 + 10) * 本种珍珠的单价,其中品质次的珍珠可以用品质好的珍珠代替,求这样做需要支付的最小价格 



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define inf 9999
#define INF -9999

using namespace std;

int n,m;
int a[110],b[110];
int sum[110];
int dp[110];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum[0] = 0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
            sum[i] = sum[i-1] + a[i];
        }
        dp[0] = 0;
        for(int i=1;i<=n;i++)
        {
            dp[i] = dp[i-1] + (a[i]+10)*b[i];
            for(int j=0;j<=i;j++)
            {
                dp[i] = min(dp[i],(((sum[i]-sum[j])+10)*b[i]+dp[j]));
            }
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}


版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

POJ 1260 Pearls(DP)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/47393241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!