标签:
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 43149 |
|
Accepted: 17482 |
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
该题的大意是求两个字符串的最长公共子序列
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max(a,b) a>b?a:b
char a[1100],b[1100];
int x[1100][1100];
int main()
{
int i,j,k;
while(scanf("%s%s",a,b)!=EOF)
{
int len=strlen(a);
int len1=strlen(b);
memset(x,0,sizeof(0));
for(i=1;i<=len;i++)
{
for(j=1;j<=len1;j++)
{
if(a[i-1]==b[j-1])
x[i][j]=x[i-1][j-1]+1;
else x[i][j]=max(x[i][j-1],x[i-1][j]);
}
}
printf("%d\n",x[len][len1]);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Common Subsequence
标签:
原文地址:http://blog.csdn.net/l15738519366/article/details/47395143