码迷,mamicode.com
首页 > 其他好文 > 详细

Hie with the Pie

时间:2015-08-10 13:37:15      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=3311

Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5519 Accepted: 2969

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

题意: 题意:有个人要给N个城市送N份披萨,出发点为0。给出一个N+1 * N+1 矩阵表示 0-N这 N+1个点之间的单向距离。问你从0依次送完N个披萨后返回到0的最短时间

解题思路:状态压缩+floyd算法 。把是否经过N个城市压缩成1<

#include<iostream>
#define INF 100000000
using namespace std;
int dis[12][12];
int dp[1<<11][12];
int n,ans,_min;
int main()
{
    ///freopen("in.txt","r",stdin);
    while(scanf("%d",&n) && n)
    {
        for(int i = 0;i <= n;++i)
            for(int j = 0;j <= n;++j)
                scanf("%d",&dis[i][j]);
        for(int k = 0;k <= n;++k)
            for(int i = 0;i <= n;++i)
                for(int j = 0;j <= n;++j)
                    if(dis[i][k] + dis[k][j] < dis[i][j])
                        dis[i][j] = dis[i][k] + dis[k][j];

        for(int S = 0;S <= (1<<n)-1;++S)///枚举所有状态,用位运算表示
            for(int i = 1;i <= n;++i)
            {
                if(S & (1<<(i-1)))///状态S中已经过城市i
                {
                    if(S == (1<<(i-1))) dp[S][i] = dis[0][i];///状态S只经过城市I,最优解自然是从0出发到i的dis,这也是DP的边界
                    else///如果S有经过多个城市
                    {
                        dp[S][i] = INF;
                        for(int j = 1;j <= n;++j)
                        {
                            if(S & (1<<(j-1)) && j != i)///枚举不是城市I的其他城市
                                dp[S][i] = min(dp[S^(1<<(i-1))][j] + dis[j][i],dp[S][i]);
                            ///在没经过城市I的状态中,寻找合适的中间点J使得距离更短,和FLOYD一样
                        }
                    }
                }
            }
        ans = dp[(1<<n)-1][1] + dis[1][0];
        for(int i = 2;i <= n;++i)
            if(dp[(1<<n)-1][i] + dis[i][0] < ans)
                ans = dp[(1<<n)-1][i] + dis[i][0];
        printf("%d/n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Hie with the Pie

标签:

原文地址:http://blog.csdn.net/hellohelloc/article/details/47397147

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!