码迷,mamicode.com
首页 > 其他好文 > 详细

Ikki's Story IV - Panda's Trick (poj 3207 2-SAT)

时间:2015-08-10 14:55:58      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:ikkis story iv - pan   poj 3207   2-sat   

Language:
Ikki‘s Story IV - Panda‘s Trick
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 8796   Accepted: 3241

Description

liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki.

liympanda has a magic circle and he puts it on a plane, there are n points on its boundary in circular border: 0, 1, 2, …, n ? 1. Evil panda claims that he is connecting m pairs of points. To connect two points, liympanda either places the link entirely inside the circle or entirely outside the circle. Now liympanda tells Ikki no two links touch inside/outside the circle, except on the boundary. He wants Ikki to figure out whether this is possible…

Despaired at the minesweeping game just played, Ikki is totally at a loss, so he decides to write a program to help him.

Input

The input contains exactly one test case.

In the test case there will be a line consisting of of two integers: n and m (n ≤ 1,000, m ≤ 500). The following m lines each contain two integers ai and bi, which denote the endpoints of the ith wire. Every point will have at most one link.

Output

Output a line, either “panda is telling the truth...” or “the evil panda is lying again”.

Sample Input

4 2
0 1
3 2

Sample Output

panda is telling the truth...

Source



题意:有n个点在一个圆上,标号0~n-1,有m条线段告诉两个端点的标号,每条线段可以在画在圆内也可以画在圆外,问这m条线段能否不向交。

思路:2-SAT模板题,把每条线段当做节点,每条线有两种状态(圆内和圆外,两者只能取其一),建图后求强连通,看 i 和 i‘ 是否在同一个连通分量,若在则无解,否则有解。

参考:由对称性解2-SAT问题  还有 kuangbin神牛的总结点击打开链接

代码:

#include <iostream>
#include <functional>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

#define INF 0x3f3f3f3f
#define mod 1000000009
const int maxn = 1005;
const int MAXN = 2005;
const int MAXM = 200010;
const int N = 1005;

struct Edge
{
    int to,next;
}edge[MAXM];

int head[MAXN],tot;

void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
}

void addedge(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}

int Low[MAXN],DFN[MAXN],Stack[MAXN],Belong[MAXN];
int Index,scc,top;
bool Instack[MAXN];

void Tarjan(int u)
{
    int v;
    Low[u]=DFN[u]=++Index;
    Stack[top++]=u;
    Instack[u]=true;
    for (int i=head[u];~i;i=edge[i].next)
    {
        v=edge[i].to;
        if (!DFN[v])
        {
            Tarjan(v);
            if (Low[u]>Low[v])
                Low[u]=Low[v];
        }
        else if (Instack[v]&&Low[u]>DFN[v])
            Low[u]=DFN[v];
    }
    if (Low[u]==DFN[u])
    {
        ++scc;
        do{
            v=Stack[--top];
            Instack[v]=false;
            Belong[v]=scc;
        }while (v!=u);
    }
    return ;
}

bool solvable(int n)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));
    Index=scc=top=0;
    for (int i=0;i<n;i+=2)
        if (!DFN[i])
            Tarjan(i);
    for (int i=0;i<n;i+=2)
    {
        if (Belong[i]==Belong[i^1])
            return false;
    }
    return true;
}

struct Line
{
    int s,t;
}line[MAXN];

int n,m;

int main()
{
#ifndef ONLINE_JUDGE
    freopen("C:/Users/lyf/Desktop/IN.txt","r",stdin);
#endif
    int i,j;
    scanf("%d%d",&n,&m);
    init();
    for (i=0;i<m;i++)
    {
        scanf("%d%d",&line[i].s,&line[i].t);
        if (line[i].s>line[i].t) swap(line[i].s,line[i].t);
    }
    for (i=0;i<m;i++)
    {
        for (j=i+1;j<m;j++)
        {
            if (line[i].s<line[j].s&&line[i].t>line[j].s&&line[i].t<line[j].t||line[j].s<line[i].s&&line[j].t>line[i].s&&line[j].t<line[i].t)
            {
                addedge(2*i,2*j+1);
                addedge(2*j+1,2*i);
                addedge(2*j,2*i+1);
                addedge(2*i+1,2*j);
            }
        }
    }
    if (solvable(m*2))
        printf("panda is telling the truth...\n");
    else
        printf("the evil panda is lying again\n");
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Ikki's Story IV - Panda's Trick (poj 3207 2-SAT)

标签:ikkis story iv - pan   poj 3207   2-sat   

原文地址:http://blog.csdn.net/u014422052/article/details/47397421

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!