码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 1159 Common Subsequence【LCS】【DP】

时间:2015-08-10 14:57:48      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:dp

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28494    Accepted Submission(s): 12735


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 


很基础的一道LCS。下面给出第一种情况的DP路线,如下图。希望可以帮助大家。
技术分享
AC代码:

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
char a[1000],s[1000];
int dp[1000][1000];
int main()
{
    int i,j,k;
    while(scanf("%s%s",a,s)!=EOF)
    {
    	memset(dp,0,sizeof(dp));
        int l=strlen(a);
        int le=strlen(s);
        for(i=1;i<=l;i++)
        {
            for(j=1;j<=le;j++)
            if(a[i-1]==s[j-1])//判断左侧和上侧字符是否相等 
                dp[i][j]=dp[i-1][j-1]+1;//把左上侧的dp值+1 
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);//取左侧或上侧的最大dp值    
        }
        printf("%d\n",dp[l][le]);
    }
    return 0;
}


     

版权声明:原创文章,有借鉴之处,多多支持。hhh

hdoj 1159 Common Subsequence【LCS】【DP】

标签:dp

原文地址:http://blog.csdn.net/liu6886/article/details/47397221

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!