码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj-1034-Candy Sharing Game

时间:2015-08-10 18:12:23      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3812 Accepted Submission(s): 2377


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0

Sample Output
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

Source

#include<stdio.h>
#include<string.h>
int a[10000];
int n;
bool judge(){
	for(int i=0;i<n-1;++i){
		if(a[i]!=a[i+1]) return false;
	}
	return true;
}
int main(){
	while(~scanf("%d",&n),n){	
	    int ncas=0,i,t1,t2;
		for(i=0;i<n;++i) scanf("%d",&a[i]);
		while(!judge()){
			ncas++;	
		    t2=a[0];
			for(i=1;i<=n;++i){
				t1=a[i%n];
				a[i%n]=a[i%n]/2+t2/2;
				t2=t1;
			}
			for(i=0;i<n;++i)
			  if(a[i]&1) a[i]++;
		}
		printf("%d %d\n",ncas,a[0]);
	}
	return 0;
}

We have carefully selected several similar problems for you: 1035 1031 1037 1038 1015

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdoj-1034-Candy Sharing Game

标签:

原文地址:http://blog.csdn.net/qq_18062811/article/details/47401705

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!