码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1513Palindrome

时间:2015-08-10 20:14:09      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:杭电   lcs   滚动数组   

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3919    Accepted Submission(s): 1341


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
5 Ab3bd
 

Sample Output
2
 

Source
 
好难好难得一道题,刚开始没有思路,后来想到把数组反转存起来用lcs,代码都写得收尾了发现,dp数组定到5000*5000妥妥的超内存,后来听大神说还要用滚动数组,就试了试,效果蛮好的,很开心的一次a题,一下就a了,下次还问大神,五星好评哦。
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
char c[5050],s[5050];
int dp[2][5050];//滚动数组 
int i,n,m,j;
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		scanf("%s",c);
		for(i=0;i<n;i++)
		s[i]=c[n-i-1];
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			int x=i%2;//因为模拟一下,第一维只用了两个数,所以循环使用就行了,只要第二维改变着,整体就改变着 
			int y=(i-1)%2;//lcs模板 
			if(s[j-1]==c[i-1])
			dp[x][j]=dp[y][j-1]+1;
			else
			dp[x][j]=max(dp[y][j],dp[x][j-1]);
		}
		int sum=dp[n%2][n];
		printf("%d\n",n-sum);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

杭电1513Palindrome

标签:杭电   lcs   滚动数组   

原文地址:http://blog.csdn.net/z8110/article/details/47402043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!