码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2752 Seek the Name, Seek the Fame (KMP的next函数运用)

时间:2015-08-10 23:45:57      阅读:983      评论:0      收藏:0      [点我收藏+]

标签:

Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14188   Accepted: 7068

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father‘s name and the mother‘s name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:给一个字符串S,判断在什么下标的时候,前缀和后缀相等,输出前缀和后缀相等的点。

分析:next数组的一种很巧妙的用法

next数组表示的意义是当前下标前面k字符和开头的前面k个字符相等

技术分享

所以就会有xy=ab(用xy表示x~y的这一段),则next[b]=y,那么下次就从y这个位置开始匹配

技术分享

如果xk=wy,因为xy=ab,故wy=lb,所以xk=lb,就得到了前缀和后缀相等。

如此匹配直到next[i]=-1,期间记录下下标

技术分享
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=100000+5;
char str[MAXN];
int nex[MAXN];
int ans[MAXN];
int n;
void getnext()
{
    int j=0,k=-1;
    nex[0]=-1;
    while(j<n)
    {
        if(k==-1 || str[j]==str[k])
            nex[++j]=++k;
        else
            k=nex[k];
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%s",str)!=EOF)
    {
        n=strlen(str);
        getnext();
        int i=n,tot=0;
        while(nex[i]!=-1)
        {
            ans[tot++]=i;
            i=nex[i];
        }
        for(int i=tot-1;i>=0;i--)
        {
            if(i==tot-1) printf("%d",ans[i]);
            else printf(" %d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}
View Code

 

POJ 2752 Seek the Name, Seek the Fame (KMP的next函数运用)

标签:

原文地址:http://www.cnblogs.com/clliff/p/4719439.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!