码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1856 More is better(并查集)

时间:2015-08-11 01:29:32      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:并查集   图论   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1856

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 18985    Accepted Submission(s): 6990


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


一定要仔细看题目啊!!!

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)

时间限制虽然在1s 但是内存放的很宽啊!, 所以什么数组存不下等等的顾虑都抛开吧,大胆的开数组!

【代码】

#include <cstdio>
const int maxn= 10000000+10;
int father[maxn];
int num[maxn];
int Find(int x){
	while(x!=father[x]){ //路径压缩迭代版
		father[x]=father[father[x]];
		x=father[x];
	}
	return father[x];
}
void Union(int a,int b){ //合并
	int p=Find(a);
	int q=Find(b);
	if(p!=q){
		father[p]=q;
		num[q]+=num[p];
	}
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){ 
		if(n==0){ //只剩下一个人的时候, pair数是0, 人数是1;
			puts("1");continue;
		}
		for(int i=1;i<=maxn;i++){
			num[i]=1;
			father[i]=i;
		}
		int a,b;
		int Max=0;
		for(int i=0;i<n;i++){
			scanf("%d%d",&a,&b);
			if(a>Max)
				Max=a;
			if(b>Max)
				Max=b;
			Union(a,b);
		}
		int max=0;
		 for(int i=1;i<=Max;i++){
			 if(num[i]>max)
				  max=num[i];
		 }
		printf("%d\n",max);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1856 More is better(并查集)

标签:并查集   图论   

原文地址:http://blog.csdn.net/chaiwenjun000/article/details/47405999

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!