码迷,mamicode.com
首页 > 其他好文 > 详细

Seek the Name, Seek the Fame poj 2752

时间:2015-08-11 10:08:21      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:poj2725   kmp   seek the name   seek the fame   

Seek the Name, Seek the Fame

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Problem Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father‘s name and the mother‘s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
 

Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
 

Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.
 

Sample Input
ababcababababcabab aaaaa
 

Sample Output
2 4 9 18 1 2 3 4 5
 本题,乍一看,似乎不太懂。其实题意就是:
大致题意:
    给出一个字符串str,求出str中存在多少子串,使得这些子串既是str的前缀,又是str的后缀。从小到大依次输出这些子串的长度。
    对于所定义的next数组(我用的p数组),                                                        --()--
                                                              a  a  a   a  a                                    --------()---------
                                                             -1  0  1   2   3  4   next 数组              ----------------------()
      根据next数组的组成:  如图:
      首先其记录串长为i=5,然后用循环求next[i]并记录其值,即可得解!
  代码如下:
    
#include<stdio.h>
#include<string.h>
const int max=400010;
char str[max],ch[max];
int ans[max],p[max],len,len1;
void Getp()//取出p数值(即next数组) 
{
    int i=0,j=-1;
    p[i]=j;
    while(i<len)
    {
        if(j==-1||str[i]==str[j])
        {
            i++;j++;
            p[i]=j;
        }
        else
        j=p[j];
     }
    }
int main()
{
   while(scanf("%s",str)!=EOF)
   {
       int i,j=1;
       len=strlen(str);
       Getp();
       i=len;
       while(p[i]!=0)//循环求p数组(即next数组) 
       {
           ans[j++]=p[i];
           i=p[i];
    }
     ans[0]=len;
     for(i=j-1;i>0;i--)
      {
          printf("%d ",ans[i]);
      }printf("%d\n",ans[0]);
   }
   return 0;
}
原题目:Seek the Name, Seek the Fame  poj 2752
                                                         
                                        
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

Seek the Name, Seek the Fame poj 2752

标签:poj2725   kmp   seek the name   seek the fame   

原文地址:http://blog.csdn.net/zhangxiaoxiang123/article/details/47414375

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!