码迷,mamicode.com
首页 > 其他好文 > 详细

杭电(hdu)ACM 4287 Intelligent IME

时间:2015-08-11 16:23:14      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:hdu   acm   stl   map映射容器   

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3453    Accepted Submission(s): 1647


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1 3 5 46 64448 74 go in night might gn
 

Sample Output
3 2 0
 
用STL类库中的map实现,是一道水题。
代码如下:
#include <iostream>
#include <string>
#include <map>
#include <cstring>
using namespace std;

map<string,int> m1;
int main()
{
    string str;
    string num[5000];
    int T,n,m,l;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        l=n;
        for(int i=0;i<n;i++)
        {
            cin>>num[i];
        }
        while(m--)
        {
            cin>>str;
            for(int i=0;i<str.length();i++)
            {
                if(str[i]==‘a‘||str[i]==‘b‘||str[i]==‘c‘)str[i]=‘2‘;
                else if(str[i]==‘d‘||str[i]==‘e‘||str[i]==‘f‘)str[i]=‘3‘;
                else if(str[i]==‘g‘||str[i]==‘h‘||str[i]==‘i‘)str[i]=‘4‘;
                else if(str[i]==‘j‘||str[i]==‘k‘||str[i]==‘l‘)str[i]=‘5‘;
                else if(str[i]==‘m‘||str[i]==‘n‘||str[i]==‘o‘)str[i]=‘6‘;
                else if(str[i]==‘p‘||str[i]==‘q‘||str[i]==‘r‘||str[i]==‘s‘)str[i]=‘7‘;
                else if(str[i]==‘t‘||str[i]==‘u‘||str[i]==‘v‘)str[i]=‘8‘;
                else if(str[i]==‘w‘||str[i]==‘x‘||str[i]==‘y‘||str[i]==‘z‘)str[i]=‘9‘;
                m1[str]++;
            }
        }
        for(int i=0;i<n;i++)
        {
            cout<<m1[num[i]]<<endl;
        }
        m1.clear();
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。欢迎读者评论和指正

杭电(hdu)ACM 4287 Intelligent IME

标签:hdu   acm   stl   map映射容器   

原文地址:http://blog.csdn.net/it142546355/article/details/47420131

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!