码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5372 Segment Game

时间:2015-08-11 23:33:14      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:树状数组   hdu   多校   

Problem Description
Lillian is a clever girl so that she has lots of fans and often receives gifts from her fans.

One day Lillian gets some segments from her fans Lawson with lengths of 1,2,3... and she intends to display them by adding them to a number line.At the i-th add operation,she will put the segment with length of i on the number line.Every time she put the segment on the line,she will count how many entire segments on that segment.During the operation ,she may delete some segments on the line.(Segments are mutually independent)
 

Input
There are multiple test cases.

The first line of each case contains a integer n — the number of operations(1<=n<=2?105,n<=7?105)

Next n lines contain the descriptions of the operatons,one operation per line.Each operation contains two integers a , b. 

if a is 0,it means add operation that Lilian put a segment on the position b(|b|<109) of the line.
(For the i-th add operation,she will put the segment on [b,b+i] of the line, with length of i.)

if a is 1,it means delete operation that Lilian will delete the segment which was added at the b-th add operation.
 

Output
For i-th case,the first line output the test case number.

Then for each add operation,ouput how many entire segments on the segment which Lillian newly adds.
 

Sample Input
3 0 0 0 3 0 1 5 0 1 0 0 1 1 0 1 0 0
 

Sample Output
Case #1: 0 0 0 Case #2: 0 1 0 2
题意:给你n个操作,每次增加线段或者删除第i个增加操作中增加的线段,问你每次增加操作中,所增加的线段会覆盖多少条完整的线段。
这题思路挺简单,用树状数组或者线段树进行单点更新,然后求得区间内包含的线段即可,但有两个注意点:
1.每次增加线段都比之前的所有线段长,所以求区间内线段数的时候不用考虑横穿整个区间,只需考虑全部在区间内或者部分在区间内,部分在区间外的线段。
2.这里的删减操作是删除第i个增加操作的线段,增加操作也是增加一条长为当前第i个增加操作的长度是i,注意是增加操作,不是总的操作!这里wa了10多次。。。
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 200050
struct node{
	int l,r,f;
}a[maxn];
int b1[2*maxn],b2[2*maxn],pos[2*maxn],caozuo[2*maxn];
int lowbit(int x){
	return x&(-x);
}

void update1(int pos,int num){
	while(pos<=2*maxn){
		b1[pos]+=num;pos+=lowbit(pos);
	}
}

int getsum1(int pos){
	int num=0;
	while(pos>0){
		num+=b1[pos];pos-=lowbit(pos);
	}
	return num;
}

void update2(int pos,int num){
	while(pos<=2*maxn){
		b2[pos]+=num;pos+=lowbit(pos);
	}
}

int getsum2(int pos){
	int num=0;
	while(pos>0){
		num+=b2[pos];pos-=lowbit(pos);
	}
	return num;
}

int main()
{
	int n,m,i,j,d,tot,s1,s2,t1,t2,num1=0,caozuo1;
	while(scanf("%d",&n)!=EOF)
	{
		tot=0;caozuo1=0;
		//memset(caozuo,0,sizeof(caozuo));
		//memset(pos,0,sizeof(pos));
		for(i=1;i<=n;i++){
			scanf("%d%d",&a[i].f,&d);
			if(a[i].f==0){
				caozuo1++;caozuo[caozuo1]=i;
				//caozuo++;a[i].idx=caozuo;
				a[i].l=d;a[i].r=d+caozuo1;
				tot++;pos[tot]=a[i].l;
				tot++;pos[tot]=a[i].r;
			}
			else if(a[i].f==1){
				d=caozuo[d];
				a[i].l=a[d].l;a[i].r=a[d].r;
			}
		}
		num1++;
		printf("Case #%d:\n",num1);
		memset(b1,0,sizeof(b1));
		memset(b2,0,sizeof(b2));
		sort(pos+1,pos+1+tot);
		m=1;
		for(i=2;i<=tot;i++){
			if(pos[i]!=pos[m]){
				m++;pos[m]=pos[i];
			}
		}
		for(i=1;i<=n;i++){
			if(a[i].f==0){
				t1=lower_bound(pos+1,pos+m+1,a[i].l)-pos;
				t2=lower_bound(pos+1,pos+m+1,a[i].r)-pos;
				s1=getsum1(t2)-getsum1(t1-1);
				s2=getsum2(t2);
				printf("%d\n",s1-s2);
				update1(t1,1);
				update2(t1,1);
				update2(t2,-1);
			}
			else if(a[i].f==1){
				t1=lower_bound(pos+1,pos+m+1,a[i].l)-pos;
				t2=lower_bound(pos+1,pos+m+1,a[i].r)-pos;
				update1(t1,-1);
				update2(t1,-1);
				update2(t2,1);
			}
		}	
	}
	return 0;
}
/*
5
0 3
0 4
0 1
0 4
0 -1
*/



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5372 Segment Game

标签:树状数组   hdu   多校   

原文地址:http://blog.csdn.net/kirito_acmer/article/details/47427711

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!