码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2007 Scrambled Polygon(凸包)

时间:2015-08-12 01:25:19      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:poj 2007 scrambled p   凸包   

Scrambled Polygon
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7568   Accepted: 3604

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn‘t have any "dents".) 
技术分享

The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 
技术分享 
技术分享

Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999. The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip taken along the polygon‘s border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input

0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output

(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)

Source

题意:给出若干个点,求出它们的凸包,并且按原点为第一点的逆时针方向输出。

#include<cstring>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
#define PI 3.1415926

const double eps=1e-12;
#define _sign(x) ((x)>eps?1:((x)<-eps?2:0))

using namespace std;
const int MAXN = 1010;

struct Point {
    double x,y;
    Point() {}
    Point(double _x,double _y) {
        x = _x;
        y = _y;
    }
    Point operator -(const Point &b)const {
        return Point(x - b.x,y - b.y);
    }
//叉积
    double operator ^(const Point &b)const {
        return x*b.y - y*b.x;
    }
//点积
    double operator *(const Point &b)const {
        return x*b.x + y*b.y;
    }
//绕原点旋转角度B(弧度值),后x,y的变化
    void transXY(double B) {
        double tx = x,ty = y;
        x = tx*cos(B) - ty*sin(B);
        y = tx*sin(B) + ty*cos(B);
    }
};
Point L[MAXN];
int Stack[MAXN],top;
int n;
double m;

double dist(Point a,Point b) {
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int sgn(double x) {
    if(fabs(x)<eps)return 0;
    if(x<0)return -1;
    return 1;
}
//相对于L[0]的极角排序
bool _cmp(Point p1,Point p2) {
    double tmp = (p1-L[0])^(p2-L[0]);
    if(sgn(tmp) > 0)return true;
    else if(sgn(tmp) == 0 && sgn(dist(p1,L[0]) - dist(p2,L[0])) <= 0)
        return true;
    else return false;
}
void Graham(int n) {
    Point p0;
    int k = 0;
    p0 = L[0];
//找最下边的一个点
    for(int i = 1; i < n; i++) {
        if( (p0.y > L[i].y) || (p0.y == L[i].y && p0.x > L[i].x) ) {
            p0 = L[i];
            k = i;
        }
    }
    swap(L[k],L[0]);
    sort(L+1,L+n,_cmp);
    if(n == 1) {
        top = 1;
        Stack[0] = 0;
        return;
    }
    if(n == 2) {
        top = 2;
        Stack[0] = 0;
        Stack[1] = 1;
        return ;
    }
    Stack[0] = 0;
    Stack[1] = 1;
    top = 2;
    for(int i = 2; i < n; i++) {
        while(top > 1 && sgn((L[Stack[top-1]]-L[Stack[top-2]])^(L[i]-L[Stack[top-2]])) <= 0)
            top--;
        Stack[top++] = i;
    }
}

int main() {
    //freopen("test.in","r",stdin);
    n=0;
    while(~scanf("%lf%lf",&L[n].x,&L[n].y)) {
        n++;
    }
    Graham(n);
    double ans=0;
    int p=0;
    for(int i=0; i<top; i++) {
        int u=Stack[i];
        if(L[u].x==0&&L[u].y==0) {
            p=i;
            break;
        }
    }
    for(int i=p; i<top; i++)
        printf("(%.0f,%.0f)\n",L[Stack[i]].x,L[Stack[i]].y);
    for(int i=0; i<p; i++) {
        printf("(%.0f,%.0f)\n",L[Stack[i]].x,L[Stack[i]].y);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2007 Scrambled Polygon(凸包)

标签:poj 2007 scrambled p   凸包   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/47430595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!