码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2406 Power Strings KMP

时间:2015-08-12 16:57:08      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:hdu   kmp   字符串匹配   c语言   

                                                                         Power Strings

                                                              Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意: 求出最长的循环次数
题解:
如下图:
下标
0 1 2 3 4 5 6 7 8 9 10
字符 a b a b a b a b a b  
next -1 0 0 1 2 3 4 5 6 7 8
由图可知next[10]=8 表示前八个字符与后八个字符相同,且为前10-8个字符的循环出现,也就是说最大的循环次数是=10/(10-8).

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int M = 1000010; 
int nxt[M];
char T[M];
int n,m;
int ans;
void getnext(){
    int j, k;
    j = 0; k = -1; nxt[0] = -1;
    while(j<m){
        if (k==-1 || T[j]==T[k]){
            nxt[++j] = ++k;
        }
        else{
            k = nxt[k];
        }
    }
}
int main()
{		
  while(scanf("%s",&T)!=EOF){
  		if(T[0]=='.') break;
 		m=strlen(T);
        getnext();
        if(m%(m-nxt[m])==0) printf("%d\n",m/(m-nxt[m]));//****      
        else printf("1\n");    
   }
 return 0;  	
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 2406 Power Strings KMP

标签:hdu   kmp   字符串匹配   c语言   

原文地址:http://blog.csdn.net/taluoyaxin/article/details/47445439

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!