标签:
To the Max
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 43715 |
|
Accepted: 23160 |
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
Source
#include<stdio.h>
#include<string.h>
const int inf=-1<<20;
int m[101][101];
int sum[101][101];
int max(int a,int b){
return a>b?a:b;
}
int main(){
int n;
while(~scanf("%d",&n)){
memset(sum,0,sizeof(sum));
int i,j,k;
for(i=1;i<=n;++i){
for(j=1;j<=n;++j){
scanf("%d",&m[i][j]);
sum[i][j]=sum[i-1][j]+m[i][j];
}
}
int maxn=-1000;
for(i=1;i<=n;++i){
int d=-1000;
for(j=i;j<=n;++j){
int res=0;
for(k=1;k<=n;++k){
res=max(res+sum[j][k]-sum[i-1][k],sum[j][k]-sum[i-1][k]);
if(res>maxn) maxn=res;
}
}
}
printf("%d\n",maxn);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
poj-1050-To the Max【DP】
标签:
原文地址:http://blog.csdn.net/qq_18062811/article/details/47444641