码迷,mamicode.com
首页 > 其他好文 > 详细

集训第五周动态规划 G题 回文串

时间:2015-08-12 21:33:11      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

这道题类似于编辑距离,使用动态规划可解:

用dp(i,j)表示数组从i到j使其成为回文串需要加入的字符个数

那么动态规划方程为
1.min(dp(i+1,j)+1,dp(i,j-1)+1) (a[i]!=a[j])
dp(i,j)={
2.dp(i+1,j-1) (a[i]=a[j])

这道题由于n最大可达5000,因此使用int型的二维数组会超空间,可以把int型改成short型,也可以使用滚动数组。。。。

#include"iostream"
#include"cstring"
#include"cstdio"
using namespace std;

const int maxn=5010;

char a[maxn];
short dp[2][maxn];

short min(short a1,short a2)
{
    return a1<a2?a1:a2;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",a+1);
        for(int i=n-1;i>=1;i--)
        {
            for(int j=i+1;j<=n;j++)
            {
                dp[i%2][j]=min(dp[i%2][j-1]+1,dp[(i+1)%2][j]+1);
                if(a[j]==a[i])
                dp[i%2][j]=dp[(i+1)%2][j-1];
            }
        }
        cout<<dp[1][n]<<endl;
    }
    return 0;
}

 








集训第五周动态规划 G题 回文串

标签:

原文地址:http://www.cnblogs.com/zsyacm666666/p/4725487.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!