码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3371 Connect the Cities (MST)

时间:2015-08-13 20:12:39      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:hdu3371   hdu 3371   mst   

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13722    Accepted Submission(s): 3711


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
1
 

Author
dandelion
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1102 1301 1162 1198 1598 
 

Statistic | Submit | Discuss | Note

难理解的就是最后那k行,开始的数字t表示有几个城市,然后输入t个城市,表示第一个城市和第二个连接,第二个和第三个连接。。。

用kruskal算法超时的多提交两次。。当然也可以用pri算法。。不想写。。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int a,b,cost;
}c[30000];
int fa[505];
void init(int n)
{
	for(int i=1;i<=n;i++)
	fa[i]=i;
}
bool cmp(node x,node y)
{
	return x.cost<y.cost;
}
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	int n,k,m,ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d %d %d",&n,&k,&m);
		init(n);
		for(int i=0;i<k;i++)
		scanf("%d %d %d",&c[i].a,&c[i].b,&c[i].cost);
		for(int i=1;i<=m;i++)
		{
			int x,pos,pos1;
			scanf("%d %d",&x,&pos);
			for(int j=1;j<x;j++)
			{
				scanf("%d",&pos1);
				c[k].a=pos,c[k].b=pos1,c[k].cost=0;
				pos=pos1;
				k++;
			}
		}
		sort(c,c+k,cmp);
		int sum=0;
		for(int i=0;i<k;i++)
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			sum+=c[i].cost,fa[x]=y;
		}
		int count=0;
		for(int i=1;i<=n;i++)
		if(fa[i]==i)
		count++;
		if(count!=1)
		printf("-1\n");
		else
		printf("%d\n",sum);
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu3371 Connect the Cities (MST)

标签:hdu3371   hdu 3371   mst   

原文地址:http://blog.csdn.net/su20145104009/article/details/47617133

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!