标签:
Common Subsequence
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 43303 |
|
Accepted: 17580 |
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence
of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2,
4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input
data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
Source
题意:
输入两个字符串,让你求最长公共子序列(这个子序列可以不连续),所以用LCS算法很容易就能解决。虽然讲的时候有点麻烦,但是代码非常简单,看代码吧!
代码:
#include <stdio.h>
#include <string.h>
#define max(a,b) (a>b?a:b)
int n;
char a[1005],b[1005];
int p[1005][1005];
int main()
{
int len1,len2;
while(scanf("%s%s",a,b)!=EOF)
{
len1=strlen(a);
len2=strlen(b);
for(int i=1;i<=len1;i++)
for(int j=1;j<=len2;j++)
{
if(a[i-1]==b[j-1])
{
p[i][j]=p[i-1][j-1]+1;
}
else
{
p[i][j]=max(p[i-1][j],p[i][j-1]);
}
}
printf("%d\n",p[len1][len2]);
}
return 0;
}
思路:
版权声明:本文为博主原创文章,未经博主允许不得转载。
poj 1458 Common Subsequence
标签:
原文地址:http://blog.csdn.net/dxx_111/article/details/47617989