标签:
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d
distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is
followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
题解:贪心为找到每个岛屿的最大区间,既在这个区间内任何一点都可以覆盖该岛屿,因为左端点的圆向右移动,高度(y坐标)变大,再一直到右端点达到最小高度,然后判断下一个岛屿的区间是不是和该岛屿有交集,有的话只需要一个,因为在上一个岛屿的区间随意移动都可以包含有交集的岛屿。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
struct Point
{
double x;
double y;
bool operator< (Point t) const
{
return x < t.x;
}
};
Point p[1003];
int main()
{
int n;
double d;
int t = 1;
while(scanf("%d%lf",&n,&d) != EOF && n != 0)
{
double a,b;
bool flag = true;
for(int i = 0;i < n;i++)
{
scanf("%lf%lf",&a,&b);
if(b > d)
{
flag = false;
}
double t = sqrt(d * d - b * b);
p[i].x = a - t;
p[i].y = a + t;
}
printf("Case %d: ",t++);
if(!flag)
{
printf("-1\n");
continue;
}
sort(p,p + n);
int ans = 1;
int temp = 0;
for(int i = 1;i < n;i++)
{
if(p[i].y < p[temp].y) //取小的一个区间,特别注意 ,因为取大的话也许不能覆盖小的了
{
temp = i;
}
else if(p[i].x > p[temp].y)
{
ans++;
temp = i;
}
ans++;
temp = i;
}
printf("%d\n",ans);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Radar Installation
标签:
原文地址:http://blog.csdn.net/wang2534499/article/details/47624115