码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2075:Tangled in Cables 【Prim】

时间:2015-08-14 11:51:09      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:最小生成树   poj   prim   图论   

Tangled in Cables

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.
 

Input
Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house‘s owner. Each name consists of up to 20 characters {az,AZ,09} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.
 

Output
The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).
 

Sample Input
100.0 4 Jones Smiths Howards Wangs 5 Jones Smiths 2.0 Jones Howards 4.2 Jones Wangs 6.7 Howards Wangs 4.0 Smiths Wangs 10.0
 

Sample Output
Need 10.2 miles of cable
 

数组要开大~~

AC-code:

#include<cstdio>
#include<cstring>
#define max 0x3f3f3f3f
int num;
float s[10005][10005];
float prim()
{
	int k,i,j,vis[10005];
	float ans=0.0,dis[10005];
	memset(vis,0,sizeof(vis));
	for(i=1;i<num;i++)
		dis[i]=s[0][i];
	dis[0]=0;
	vis[0]=1;
	for(j=1;j<num;j++)
	{
		float min=max;
		for(i=1;i<num;i++)
			if(!vis[i]&&dis[i]<min)
			{
				k=i;
				min=dis[i];
			}
		vis[k]=1;
		for(i=1;i<num;i++)
			if(!vis[i]&&dis[i]>s[k][i])
				dis[i]=s[k][i];
	 } 
	 for(i=1;i<num;i++)
	 	ans+=dis[i];
	return ans;
}

int main()
{
	int n,i,j,k,p;
	float m,ans,total;
	char name[10000][200],str1[200],str2[200];
	scanf("%f",&total);
	scanf("%d",&num);
	for(i=0;i<num;i++)
		scanf("%s",name[i]);
	scanf("%d",&n);
	for(i=0;i<num;i++)
		for(j=i;j<num;j++)
			s[i][j]=s[j][i]=max;
	for(j=0;j<n;j++)
	{
		scanf("%s%s%f",str1,str2,&m);
		int k=-1,p=-1;
		for(i=0;i<num;i++)
		{
			if(strcmp(str1,name[i])==0)
				k=i;
			else if(strcmp(str2,name[i])==0)
				p=i;
			if(k!=-1&&p!=-1)
			{ 
				s[k][p]=s[p][k]=m;	
				break;
			}
		}
	}
	ans=prim();
	if(ans>total)
		printf("Not enough cable\n");
	else
		printf("Need %.1f miles of cable\n",ans);
	return 0;
}



 

版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2075:Tangled in Cables 【Prim】

标签:最小生成树   poj   prim   图论   

原文地址:http://blog.csdn.net/lin14543/article/details/47657809

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!