码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 1986 Bridging Signals

时间:2015-08-14 15:43:56      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Bridging Signals

Time Limit: 2 Seconds      Memory Limit: 65536 KB

‘Oh no, they‘ve done it again‘, cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

技术分享

Figure 1. To the left: The two blocks‘ ports and their signal mapping (4, 2, 6, 3, 1, 5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the ith number specifies which port on the right side should be connected to the ith port on the left side. Two signals cross if and only if the straight lines connecting the two ports of each pair do.


Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:

On the ith line is the port number of the block on the right side which should be connected to the ith port of the block on the left side.


Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.


Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6


Sample Output

3
9
1
4


这题是个典型的求最长子序列(LIS)长度的0(nlogn)算法 。

解题思路:

   维护一个单调的队列
   新的元素,如果大于队尾元素,即插入队尾
   否则二分查找比它大的最小元素,替换掉
   最后队列长度即为LIS的解

  看看下面一个例子大家应该就会更清晰点了

  1 3 7 5 9 4 8
  1
  1 3
  1 3 7
  1 3 5
  1 3 5 9
  1 3 4 9
  1 3 4 8


 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<algorithm>
using namespace std;
const int maxn=40010;
int a[maxn],b[maxn];
int n;
int w(int *a,int x,int y,int t)
{
    int L=x,R=y,M=0;
    while(L<R)
    {
        M=((R-L)>>1)+L;
        if(a[M]<t) L =M+1;
        else R=M;
    }
    return L;
}
int main()
{
    int N,t;
    cin>>N;
    while(N--)
    {
        cin>>n;
        int c=1;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin>>b[0];
        for(int i=1;i<n;i++)
        {
            cin>>t;
            if(t>b[c-1]) b[c++]=t;
            else
                b[w(b,0,c,t)]=t;
        }
        printf("%d\n",c);
    }
    return 0;
}









版权声明:本文为博主原创文章,未经博主允许不得转载。

ZOJ 1986 Bridging Signals

标签:

原文地址:http://blog.csdn.net/hellohelloc/article/details/47661853

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!