码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2367

时间:2015-08-14 19:12:30      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:

Genealogical tree
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3658   Accepted: 2433   Special Judge

Description

The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

 
题意:
 
        首先输入一个数n,代表人数,然后输入n行,每一行的输入分别代表他们自己的后代(以第i行为例:第i 行输入的是第i个人的后代),然后通过n行的输入,来确定谁最大,谁第二大,一直将所有的人都输出!(按照年龄由大到小的输出),看不懂题就画图,一画图就知道了!
 
代码:
 
//理解题意很重要! 
#include <stdio.h>
#include <string.h>
int n;
int map[105][105];
int indegree[105];
int queue[105];
void topo()
{
	int m,t=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			if(indegree[j]==0)
		    {
		  		m=j;
				break;  	
		    }
		}
		indegree[m]=-1;
		queue[t++]=m;
		for(int j=1;j<=n;j++)
		{
			if(map[m][j]==1)
			{
				indegree[j]--;
			}
		}
	}
	for(int i=0;i<n-1;i++)
		printf("%d ",queue[i]);
	printf("%d\n",queue[n-1]);
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		int a,b;
		for(int i=1;i<=n;i++)
		{
			while(scanf("%d",&a)&&a)//注意输入的格式,每一行遇到0就结束! 
			{
				if(map[i][a]==0)
				{
					map[i][a]=1;
					indegree[a]++;
				}
			}	
		}
		topo();
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2367

标签:

原文地址:http://blog.csdn.net/dxx_111/article/details/47665049

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!