码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5389 Zero Escape DP

时间:2015-08-14 19:18:24      阅读:293      评论:0      收藏:0      [点我收藏+]

标签:


一个数的数字根只和它mod~9mod 9之后的值有关,只要类似背包就能完成人员分配的计算。

具体证明:数字根=\sum_{i=0}^{w}a_i?i=0?w??a?i??,数字=\sum_{i=0}^{w}10^i*a_i?i=0?w??10?i???a?i??

数字-数字根=\sum_{i=0}^{w}(10^i-1)*a_i?i=0?w??(10?i???1)?a?i??,这个数字在modmod 99域下为00



Zero Escape

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 730    Accepted Submission(s): 362


Problem Description
Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft.

Stilwell is enjoying the first chapter of this series, and in this chapter digital root is an important factor. 

This is the definition of digital root on Wikipedia:
The digital root of a non-negative integer is the single digit value obtained by an iterative process of summing digits, on each iteration using the result from the previous iteration to compute a digit sum. The process continues until a single-digit number is reached.
For example, the digital root of 65536 is 7, because 6+5+5+3+6=25 and 2+5=7.

In the game, every player has a special identifier. Maybe two players have the same identifier, but they are different players. If a group of players want to get into a door numbered X(1X9), the digital root of their identifier sum must be X.
For example, players {1,2,6} can get into the door 9, but players {2,3,3} can‘t.

There is two doors, numbered A and B. Maybe A=B, but they are two different door.
And there is n players, everyone must get into one of these two doors. Some players will get into the door A, and others will get into the door B.
For example: 
players are {1,2,6}A=9B=1
There is only one way to distribute the players: all players get into the door 9. Because there is no player to get into the door 1, the digital root limit of this door will be ignored.

Given the identifier of every player, please calculate how many kinds of methods are there, mod 258280327.
 

Input
The first line of the input contains a single number T, the number of test cases.
For each test case, the first line contains three integers nA and B.
Next line contains n integers idi, describing the identifier of every player.
T100n105n1061A,B,idi9
 

Output
For each test case, output a single integer in a single line, the number of ways that these n players can get into these two doors.
 

Sample Input
4 3 9 1 1 2 6 3 9 1 2 3 3 5 2 3 1 1 1 1 1 9 9 9 1 2 3 4 5 6 7 8 9
 

Sample Output
1 0 10 60
 

Source
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年08月14日 星期五 14时24分21秒
File Name     :HDOJ5389.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

const int maxn=100100;
const LL mod=258280327LL;

int n,A,B,sum;
int a[maxn];

int Calu(int a,int b)
{
	int ret=(a+b)%9;
	if(ret==0) return 9;
	return ret;
}

LL dp[maxn][10];

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d%d%d",&n,&A,&B);

		sum=0;
		for(int i=1;i<=n;i++) 
		{
			scanf("%d",a+i);
			sum=Calu(sum,a[i]);
		}

		for(int i=0;i<=9;i++) dp[1][i]=0;
		dp[1][a[1]]=1;
		for(int i=2;i<=n;i++)
		{
			for(int j=1;j<=9;j++) 
				dp[i][j]=dp[i-1][j];
			dp[i][a[i]]=(dp[i][a[i]]+1)%mod;
			for(int j=1;j<=9;j++)
			{
				int c=Calu(j,a[i]);
				dp[i][c]=(dp[i][c]+dp[i-1][j])%mod;
			}
		}

		LL ans=0;

		if(Calu(A,B)==sum)
		{
			ans=dp[n][A];
			if(A==sum) ans--;
		}
		if(A==sum) ans++;
		if(B==sum) ans++;

		cout<<ans%mod<<endl;
	}

    return 0;
}




版权声明:----- from: http://blog.csdn.net/ck_boss

HDOJ 5389 Zero Escape DP

标签:

原文地址:http://blog.csdn.net/ck_boss/article/details/47664549

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!