码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1003 最大连续子序和

时间:2015-08-14 21:19:06      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1: 14 1 4
Case 2: 7 1 6
用变量记录开头和结尾,然后从第一个不断累加到最后一个
在途中,不断更新和维护【最大连续子序和】和他的开头和结尾的下表,
如果临时的连续子序和小于零 就赋0 再累加下去。。。
技术分享
#include<iostream>
#include<algorithm>
using namespace std;
class M{
public:
    int a,b,sum;
};
int x[100002];
int main(){
    int t;cin>>t;
    for(int k=1;k<=t;k++){
        if(k!=1)cout<<endl;
        int n;cin>>n;
        M t; t.a=1; t.b=1;  t.sum=-1000;
        int ta=1; int sum=0;
        for(int i=1;i<=n;i++){
            cin>>x[i];
            sum+=x[i];
            if(sum>t.sum){
                t.a=ta;
                t.b=i;
                t.sum=sum;
            }
            if(sum<0){
                sum=0;
                ta=i+1;
            }
        }
        cout<<"Case "<<k<<":"<<endl;
        cout<<t.sum<<" "<<t.a<<" "<<t.b<<endl;
    }
return 0;
}
View Code

 

hdu1003 最大连续子序和

标签:

原文地址:http://www.cnblogs.com/demodemo/p/4731103.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!