码迷,mamicode.com
首页 > 其他好文 > 详细

Triangle LOVE

时间:2015-08-14 21:34:01      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3574    Accepted Submission(s): 1401


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
Case #1: Yes Case #2: No



#include<stdio.h>
#include<string.h>
char p[2001][2001];
int s[2001],m;
void TO(int n)
{
	int flag=0;
	int i,j,k;
	for(i=0;i<n;i++)
	{
		for(j=0;j<n;j++)
		if(s[j]==0)
		break;
		if(j==n)
		{
			flag=1;
			break;
		}
		s[j]=-1;
		for(k=0;k<n;k++)
		if(p[j][k]=='1'&&s[k]!=0)
		s[k]--; 
	}
	printf("Case #%d: ",++m);
	if(flag) printf("Yes\n"); 
	else printf("No\n");
	
}
int main()
{
	int t,n;
	m=0;
	scanf("%d",&t);
	while(t--)
	{
		memset(s,0,sizeof(s));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%s",p[i]);
			for(int j=0;j<n;j++)
			{
				if(p[i][j]=='1')
				s[j]++;
			}
		}
		TO(n);
	}
	return 0;
}


再贴一个代码:

#include<stdio.h>
#include<string.h>
char p[2001][2001];
int s[2001],m;
void TO(int n)
{
	int flag=0,i,j,k,w=1000000,h;
	for(i=0;i<n;i++)
	{
		for(j=0;j<n;j++)
		if(s[j]==0)
		{
			w=j;break;
		}
		else w=1000000;
		if(w==1000000)
		{
			printf("Case #%d: ",++m);
			printf("Yes\n");
			return ;
	     }
		s[w]=-1;
		for(k=0;k<n;k++)
		if(p[w][k]=='1')
		s[k]--; 
	}
	printf("Case #%d: ",++m);
	printf("No\n");
	return ;
}
int main()
{
	int t,n;
	m=0;
	scanf("%d",&t);
	while(t--)
	{
		memset(s,0,sizeof(s));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%s",p[i]);
			for(int j=0;j<n;j++)
			{
				if(p[i][j]=='1')
				s[j]++;
			}
		}
		TO(n);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Triangle LOVE

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47666355

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!