码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1458

时间:2015-08-14 21:36:30      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

420



题意:
我们称序列 Z = < z1, z2, ..., zk >是序列X = < x1, x2, ..., xm >的子序列当且仅当存在严格上升的序列< i1, i2, ..., ik >,使得对j = 1, 2, ... ,k, 有xij = zj。比如Z = < a, b, f, c > 是X = < a, b,c, f, b, c >的子序列。现在给出两个序列X 和Y,你的任务是找到X 和Y 的最大公共子序列,也就是说要找到一个最长的序列Z,使得Z 既是X 的子序列也是Y 的子序列.
思路:
设d(i,j)为A1,A2,...Ai和B1,B2,..Bj的LCS的长度,则当A[i]=A[j]时d(I,j)d(i-1,j-1)+1,否则d(i,j)=max{d(i-1,j),d(i,j-1)},时间复杂度为O(nm),其中n和m分别是序列A和B的长度。
代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m;
int const maxn=1000;
char s[maxn],t[maxn];
int dp[maxn+1][maxn+1];
void solve()
{
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
        {
            if(s[i]==t[j])
            {
                dp[i+1][j+1]=dp[i][j]+1;
            }
            else
            {
                dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);

            }
        }
    }
    printf("%d\n",dp[n][m]);
}
int main()
{

    while(scanf("%s%s",&s,&t)!=EOF)
    {
        n=strlen(s);
        m=strlen(t);
        solve();
    }
    return 0;

}

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1458

标签:

原文地址:http://blog.csdn.net/a1967919189/article/details/47666187

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!