码迷,mamicode.com
首页 > 其他好文 > 详细

CSU 1601 War (并查集)

时间:2015-08-14 22:46:48      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:图论   并查集   


1601: War

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 202  Solved: 58
[Submit][Status][Web Board]

Description

AME decided to destroy CH’s country. In CH’ country, There are N villages, which are numbered from 1 to N. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. To defend the country from the attack of AME, CH has decided to build some roads between some villages. Let us say that two villages belong to the same garrison area if they are connected.
Now AME has already worked out the overall plan including which road and in which order would be attacked and destroyed. CH wants to know the number of garrison areas in his country after each of AME’s attack.

Input

The first line contains two integers N and M — the number of villages and roads, (2 ≤ N ≤ 100000; 1 ≤ M ≤ 100000). Each of the next M lines contains two different integers u, v (1<=u, v<=N)—which means there is a road between u and v. The next line contains an integer Q which denotes the quantity of roads AME wants to destroy (1 ≤ Q ≤ M). The last line contains a series of numbers each of which denoting a road as its order of appearance — different integers separated by spaces.

Output

Output Q integers — the number of garrison areas in CH’s country after each of AME‘s attack. Each pair of numbers are separated by a single space.

Sample Input

3 1
1 2
1
1
4 4
1 2
2 3
1 3
3 4
3
2 4 3

Sample Output

3
1 2 3

HINT

题目链接:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1601

题目大意:n个村子,m条路,依次给出连通两个村子的路,能相互连通的村子看做一个区域。再依次炸毁第 i 条路,求每次炸毁一条路后共有几个区域。

解题思路:典型的并查集,思维要反过来并,逆序把炸毁的路和并即可。时间是O(n),因此在合并每一条炸毁的路之前记录区域数目,注意如果两点已属于一块区域,则区域数目不变,如果不属于,则区域数目减1。

代码如下:

#include <cstdio>
#include <cstring>
const int maxn=100005;
int fa[maxn],ans[maxn],rd[maxn],vis[maxn];
struct  node
{
	int u,v;
}eg[maxn];
void get_fa()
{
 	for(int i=0;i<maxn;i++)
 		fa[i]=i;
}
int find(int x)
{
	return x==fa[x]?x:fa[x]=find(fa[x]);
}
void Union(int a,int b)
{
	int a1=find(a);
	int b1=find(b);
	fa[b1]=a1;
}
int main(void)
{
	int n,m,x;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int q;
		get_fa();
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=m;i++)
			scanf("%d%d",&eg[i].u,&eg[i].v);
		scanf("%d",&q);
		for(int i=1;i<=q;i++)
		{			
			scanf("%d",&rd[i]);
			vis[rd[i]]=1;
		}
		for(int i=1;i<=m;i++)
		{
			if(vis[i])continue;
			Union(eg[i].u,eg[i].v);
		}
		int a=0;
			for(int j=1;j<=n;j++)
				if(find(j)==j)
					a++;
		ans[q]=a;        //最开始的区域数目,即q条路被毁后的区域数目
		for(int i=q;i>1;i--)
		{
			if(find(eg[rd[i]].u)==find(eg[rd[i]].v))
			{
				ans[i-1]=ans[i];    //如果两个村子已经属于同一个区域,区域数目不变
				continue;
			}
			Union(eg[rd[i]].u,eg[rd[i]].v);   //如果不属于,合并,区域数目减1
			ans[i-1]=ans[i]-1;         //下标很重要,注意ans[i]表示第i条路炸毁后的区域数目,所以合并后记录的是上一条路炸毁后的情况
		}
		for(int i=1;i<=q;i++)
		{
			if(i<q)
				printf("%d ", ans[i]);
			else
				printf("%d\n",ans[i]);
		}
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

CSU 1601 War (并查集)

标签:图论   并查集   

原文地址:http://blog.csdn.net/criminalcode/article/details/47667369

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!