码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5384 AC自动机模板题,统计模式串在给定串中出现的个数

时间:2015-08-14 22:51:28      阅读:532      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=5384

Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series‘ name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are n verbal evidences, and Stilwell has m "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings Ai, and bullets are some strings Bj. The damage to verbal evidence Ai from the bullet Bj is f(Ai,Bj).
f(A,B)=i=1|A|?|B|+1[ A[i...i+|B|?1]=B ]
In other words, f(A,B) is equal to the times that string B appears as a substring in string A.
For example: f(ababa,ab)=2f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence Ai after shooting all m bullets Bj, in other words is mj=1f(Ai,Bj).
 

Input
The first line of the input contains a single number T, the number of test cases.
For each test case, the first line contains two integers nm.
Next n lines, each line contains a string Ai, describing a verbal evidence.
Next m lines, each line contains a string Bj, describing a bullet.

T10
For each test case, n,m1051|Ai|,|Bj|104|Ai|105|Bj|105
For all test case, |Ai|6?105|Bj|6?105Ai and Bj consist of only lowercase English letters
 

Output
For each test case, output n lines, each line contains a integer describing the total damage of Ai from all m bullets, mj=1f(Ai,Bj).
 

Sample Input
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

Sample Output
1 1 0 3 7

/**
hdu5384 AC自动机模板题,统计模式串在给定串中出现的个数
*/
#include<string.h>
#include<algorithm>
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
char str[100010][10010];
int num[100010],n,m;
struct Trie
{
    int next[10010*50][28],fail[10010*50],end[10010*50];
    int root,L;
    int newnode()
    {
        for(int i=0; i<26; i++)
        {
            next[L][i]=-1;
        }
        end[L++]=-1;
        return L-1;
    }
    void init()
    {
        L=0;
        root=newnode();
    }
    void insert(char *s)
    {
        int len=strlen(s);
        int now=root;
        for(int i=0; i<len; i++)
        {
            if(next[now][s[i]-'a']==-1)
            {
                next[now][s[i]-'a']=newnode();
            }
            now=next[now][s[i]-'a'];
        }
        if(end[now]==-1)///标记模式串出现的次数
        {
            end[now]=1;
        }
        else
        {
            end[now]++;
        }
    }
    void build()
    {
        queue<int>Q;
        fail[root]=root;
        for(int i=0; i<26; i++)
        {
            if(next[root][i]==-1)
            {
                next[root][i]=root;
            }
            else
            {
                fail[next[root][i]]=root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty())
        {
           // printf("**\n");
            int now=Q.front();
            Q.pop();
            for(int i=0; i<26; i++)
            {
                if(next[now][i]==-1)
                    next[now][i]=next[fail[now]][i];
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    Q.push(next[now][i]);
                }
            }
        }
    }
    void query(char* s)
    {
        memset(num,0,sizeof(num));
        int len=strlen(s);
        int now=root;
        for(int i=0; i<len; i++)
        {
            now=next[now][s[i]-'a'];
            int temp=now;
            while(temp!=root)
            {
                if(end[temp]!=-1)///统计所有模式串出现的次数,num数组在0~m之间定能取到所有end[temp]必不大于m
                {
                    num[end[temp]]+=end[temp];
                }
                temp=fail[temp];
            }
        }
        int ans=0;
        for(int i=0; i<=m; i++)
        {
            if(num[i]>0)
                ans+=num[i];
        }
        printf("%d\n",ans);
    }
} ac;
char s[10005];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%s",str[i]);
        }
        ac.init();
        for(int i=0; i<m; i++)
        {
            scanf("%s",s);
            ac.insert(s);
        }
        ac.build();
        //printf("**\n");
        for(int i=0; i<n; i++)
        {
            ac.query(str[i]);
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5384 AC自动机模板题,统计模式串在给定串中出现的个数

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/47667927

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!