码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2945 Find the Clones (map+string,hash思维)

时间:2015-08-15 00:17:48      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:poj

Find the Clones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7498   Accepted: 2780

Description

Doubleville, a small town in Texas, was attacked by the aliens. They have abducted some of the residents and taken them to the a spaceship orbiting around earth. After some (quite unpleasant) human experiments, the aliens cloned the victims, and released multiple copies of them back in Doubleville. So now it might happen that there are 6 identical person named Hugh F. Bumblebee: the original person and its 5 copies. The Federal Bureau of Unauthorized Cloning (FBUC) charged you with the task of determining how many copies were made from each person. To help you in your task, FBUC have collected a DNA sample from each person. All copies of the same person have the same DNA sequence, and different people have different sequences (we know that there are no identical twins in the town, this is not an issue).

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 20000 people, and the length 1 ≤ m ≤ 20 of the DNA sequences. The next n lines contain the DNA sequences: each line contains a sequence of m characters, where each character is either `A‘, `C‘, `G‘ or `T‘.

The input is terminated by a block with n = m = 0 .

Output

For each test case, you have to output n lines, each line containing a single integer. The first line contains the number of different people that were not copied. The second line contains the number of people that were copied only once (i.e., there are two identical copies for each such person.) The third line contains the number of people that are present in three identical copies, and so on: the i -th line contains the number of persons that are present in i identical copies. For example, if there are 11 samples, one of them is from John Smith, and all the others are from copies of Joe Foobar, then you have to print `1‘ in the first andthe tenth lines, and `0‘ in all the other lines.

Sample Input

9 6
AAAAAA
ACACAC
GTTTTG
ACACAC
GTTTTG
ACACAC
ACACAC
TCCCCC
TCCCCC
0 0

Sample Output

1
2
0
1
0
0
0
0
0

Hint

Huge input file, ‘scanf‘ recommended to avoid TLE.

Source


题目链接:http://poj.org/problem?id=2945

题目大意:给出一些基因片段,计算相同基因片段的数目,求这些数目出现的次数。

解题思路:map+hash水题,这题我用字典树也写过,参见字典树分类。

代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
using namespace std;
map <string,int>mp;
const int maxn=20005;
int ans[maxn];
int main(void)
{
	//freopen("in.txt","r",stdin);
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF&&(n+m))
	{
		int cnt=0;
		memset(ans,0,sizeof(ans));
		for(int i=0;i<=n;i++)
			mp.clear();
		for(int i=0;i<n;i++)
		{
			char s[25];
			scanf("%s",s);
			string a=s;
			ans[mp[a]]--;     //相同基因个数出现次数改变了,原来的个数出现次数减1,改变后的加1
			mp[a]++;
			ans[mp[a]]++;
		}
		for(int i=1;i<=n;i++)
			printf("%d\n",ans[i]);
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 2945 Find the Clones (map+string,hash思维)

标签:poj

原文地址:http://blog.csdn.net/criminalcode/article/details/47669177

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!