码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2406 Power Strings kmp

时间:2015-08-15 11:58:34      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:poj   c++   iostream   kmp   编程   

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 37817   Accepted: 15653

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

AC code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 1000005
using namespace std;
int next[maxn];
int main(){
    char s[maxn];
    while(scanf("%s",s)!=EOF&&strcmp(s,".")){
        int k=0,len=strlen(s),i,j;
        j=0,k=-1;
        next[0]=-1;
        while(j<len){
            if(k==-1||s[j]==s[k]){
			j++;k++;
			if(s[j]!=s[k])next[j]=k;
            else next[j]=next[k];
            }
            else k=next[k];
        }
        if(len%(len-next[len])==0)
            cout<<(len/(len-next[len]))<<'\12';
        else printf("1\n");
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2406 Power Strings kmp

标签:poj   c++   iostream   kmp   编程   

原文地址:http://blog.csdn.net/zp___waj/article/details/47680537

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!