码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1961 Period kmp

时间:2015-08-15 15:01:10      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:c++   poj   kmp   编程   iostream   

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 14726   Accepted: 7009

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source


AC code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 1000005
using namespace std;
int next[maxn];
int main(){
    char s[maxn];
    int loop=1;
    int k,len,i,j;
    while(cin>>len&&len){
        scanf("%s",s);
        printf("Test case #%d\n",loop++);
        j=0,k=-1;
        next[0]=-1;
        while(j<len){
            if(k==-1||s[j]==s[k]){
			j++;k++;
                next[j]=k;
            }
            else k=next[k];
        }
        for(int i=1;i<=len;++i){
            ///printf("next[%d]: %d \n",i,next[i]);
            if(i%(i-next[i])==0&&i/(i-next[i])>1)
                printf("%d %d\n",i,i/(i-next[i]));
        }
        putchar('\n');
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1961 Period kmp

标签:c++   poj   kmp   编程   iostream   

原文地址:http://blog.csdn.net/zp___waj/article/details/47681241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!