码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1458 Common Subsequence

时间:2015-08-15 18:05:44      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:

Description:

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input:

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output:

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output 

4
2
0
题意:多组测试实例,每组两个字符串,求出两个字符串最大的一一对应的相等字符的数目(最长公共子序列的长度)。
例如abcfbc 和 abfcab: 它们的最长公共子序列是abfc或abfb,那么它们的最长公共子序列的长度为4

a b c f b c
a 1 1 1 1 1 1
b 1 2 2 2 2 2
f 1 2 2 3 3 3
c 1 2 3 3 3 4
a 1 2 3 3 3 4
b 1 2 3 3 4 4


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=1010;

int dp[N][N];

int main ()
{
    int i, j, m, n;
    char a[N], b[N];

    while (scanf("%s %s", a, b) != EOF)
    {
        m = strlen(a);
        n = strlen(b);
        memset(dp, 0, sizeof(dp));

        for (i = 1; i <= m; i++)
        {
            for (j = 1; j <= n; j++)
            {
                if (a[i-1] == b[j-1])
                    dp[i][j] = dp[i-1][j-1] + 1;
                else
                    dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
            }
        }

        printf("%d\n", dp[m][n]);
    }

    return 0;
}

POJ 1458 Common Subsequence

标签:

原文地址:http://www.cnblogs.com/syhandll/p/4732783.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!