码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 10106 Product 高精度运算

时间:2015-08-15 18:26:41      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:c++   uva   iostream   编程   

 

J - Product
Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享


 Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

 Virtual judge 交不了 uva上不去  无奈用手机开vpn交的 心累

ACcode:

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #define maxn 10000
    using namespace std;
    char a[maxn],b[maxn];
    int ans[maxn*2];
    int main(){
        int lena,lenb;
        while(scanf("%s",a)!=EOF){
            scanf("%s",b);
            if(!strcmp(a,"0")||!strcmp(b,"0")){
                printf("0\n");
                continue;
            }
            memset(ans,0,sizeof(ans));
            lena=strlen(a);
            lenb=strlen(b);
            ans[0]=lena+lenb;
            int t1,t2;
            for(int i=lena;i>0;--i){
                for(int j=lenb;j>0;--j){
                    t1=a[i-1]-'0';
                    t2=b[j-1]-'0';
                    ans[i+j]+=t1*t2;
                }
            }
            for(int i=ans[0];i>0;--i){
                if(ans[i]>10){
                    ans[i-1]+=ans[i]/10;
                    ans[i]%=10;
                }
            }
            int t=1;
            while(ans[t]==0)t++;
            for(int i=t;i<=ans[0];++i)cout<<ans[i];
            putchar('\n');
        }
        return 0;
    }


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

UVA 10106 Product 高精度运算

标签:c++   uva   iostream   编程   

原文地址:http://blog.csdn.net/zp___waj/article/details/47683099

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!